You Are Here: Home » Articles » News

Drupal, Joomla & WordPress To End Support For PHP 4 & MySQL 4

By on July 26th, 2010 
Advertisement

WordPress has officially announced the end of support to their WordPress blogging platform for PHP version 4 and MySQL version 4. WordPress is currently in it's 3rd edition. And the next version, WordPress 3.1, due in late 2010, will be the last version of WordPress to support PHP 4.

This actually means that developers who have been creating plugins solely in PHP 4 have to buckup and roll out PHP 5 compatible versions of their plugins for WordPress.  Support for MySQL 4 after WordPress 3.1 will be dropped too. Fewer than 6 percent of WordPress users are running MySQL 4. The new required MySQL version for WordPress 3.2 will be 5.0.15.

PHP 5 has some significant performance and security related improvements over PHP 4 and other famous content management systems such Drupal and Joomla will also make PHP 5 as the minimum PHP version requirement in their upcoming releases, both due out this year.

For the convinience of users, WordPress has created the Health Check plugin to help users determine which versions of PHP and MySQL are provided their respective Web hosts. You can install this plugin to find out if your host supports the requirements for the newer versions of WordPress. In order to install it, simply open the following link in your browser:

http://<Your-Wordpress-Blog-URL>/wp-admin/plugin-install.php?tab=plugin-information&plugin=health-check

Should you require any help installing the health check plugin or finding out the PHP & MySQL version that your webhost provides, just mail us a request to: mailman [at] digitizor [dot] com and we will get back.

Advertisement



Related Posts by Tags: , , ,





Drupal, Joomla & WordPress To End Support For PHP 4 & MySQL 4 was originally published on Digitizor.com on July 26, 2010 - 10:15 am (Indian Standard Time)